Page 1 of 1

RMI Registry Inspector

PostPosted: Wed Dec 01, 2010 2:01 pm
by michaeln31
Hi all,

My problem is on two parts, which I hope are related. In the RMI Registry Inspector I have never been able to see details relating to the "Class hierarchy" or the "Available Methods". Is there any main reason why I wouldn't be able to see this? My "shot in the dark" opinion is that it has to do with the stubs. My server source folder contains two folders, server and common. The common folder holds interface classes for the client and server. Because my code is supposed to be "activatable" I run my code through the command line.

Here is what i run for the server:

javac -d . common/*.java
javac -d . server/*.java
rmic -d . server.ChatRoomServerImpl
start rmiregistry
start rmid
java -Djava.rmi.server.codebase=file:\server\ server.ChatRoomServer

and this for the client:

javac -d . common/*.java

javac -d . client/*.java

java client.ClientChatRoomLoginGUI

I think that, in theory, this should work but i get the "java.lang.ClassNotFoundException: server.ChatRoomServerImpl_Stub" exception. I can attach source code if it helps.

Thanks for any help,



Re: RMI Registry Inspector

PostPosted: Wed Dec 01, 2010 2:19 pm
by michaeln31
I actually just got an answer for the second part of my question, I just skipped the part where I created a stub and it worked fine.